PDA

View Full Version : Forum Upgrade Bug Reporting Thread



DMXX
12-24-2017, 04:41 AM
Hi all,

As stated in the "Announcements" thread, please report any general functionality or accessibility issues in this thread as we undergo our upgrade.

Thank you!

[Edit]: Will re-open this thread after vB 4.2.5 and PHP bug addressing with host.

DMXX
12-24-2017, 03:40 PM
Just going to list a couple of known issues that have emerged so our regulars know we're aware:

- Activity Stream not updating
- Unable to go to the last page of some threads
- "Quick Post" returns a 500 error
- Frequent double posting

[Edit @ 30/12/17]: Per the recent announcement, I've fixed all of these bugs over tonight. The only on-going issue is SSL certification not being displayed on all pages, but that is more a formality than anything else.

If there is anything, let us know!

C J Wyatt III
12-30-2017, 03:07 PM
When I do 'New Posts' and look at a thread then do New Posts' again, it drops the viewed thread off of the list instead of keeping it but showing it not in bold.

I am curious if others are having the same problem.

Jack

firemonkey
12-30-2017, 04:04 PM
Posted "Finnish connection" showing in autosomal subforum , but not when clicking on new posts.

firemonkey
12-30-2017, 04:06 PM
When I do 'New Posts' and look at a thread then do New Posts' again, it drops the viewed thread off of the list instead of keeping it but showing it not in bold.

I am curious if others are having the same problem.

Jack

Same here.

khanabadoshi
12-30-2017, 04:54 PM
User kakiasumi can't make posts, but he can send PMs and like posts. Obviously, he can't post here to let you guys know.

parasar
12-30-2017, 11:06 PM
The post counter seems stuck.

DMXX
12-30-2017, 11:43 PM
Addressing each so far:

The "New Posts" feature was always supposed to just show the latest posts that hadn't been seen by a user. For a chronological and static order of all recent posts, we have the "Activity Stream (https://anthrogenica.com/activity.php)".

If the "New Posts" feature was showing posts that had already been seen after viewing before, that would've been either a benign bug (unlikely) or one of the other founding admins tinkered with the settings prior to launch in 2012 (likely), as it shouldn't have been doing that. There would be no need for the Activity Stream otherwise!

firemonkey's highlighting of the "Finnish connection" thread not turning up in "New Posts" is probably due to the search index being out of date (updating now). Will update this post when I see confirmation it has been resolved.

kakiasumi was unable to post for reasons that are separate from the upgrades. I've manually overrode those changes and he'll be able to interact in the forum area as before. I'll be sending him a PM shortly.

Finally, regarding the post counter, I've reset the forum's post count and have tested it out in a public thread.

C J Wyatt III
12-31-2017, 12:53 AM
Addressing each so far:

The "New Posts" feature was always supposed to just show the latest posts that hadn't been seen by a user. For a chronological and static order of all recent posts, we have the "Activity Stream (https://anthrogenica.com/activity.php)".

If the "New Posts" feature was showing posts that had already been seen after viewing before, that would've been either a benign bug (unlikely) or one of the other founding admins tinkered with the settings prior to launch in 2012 (likely), as it shouldn't have been doing that. There would be no need for the Activity Stream otherwise!


Thanks, but Activity Stream is not as compact and takes more frames to scan recent posts. I liked New Posts working the way it wasn't supposed to. Have you had any complaints about it over the last five years? I hope you will change it back. It was easy to tell when a thread had a new post after your looked at it, because it became bold again.

Jack Wyatt

DMXX
12-31-2017, 02:05 AM
I understand. After looking into the matter, it does look like one of my colleagues tinkered with an old setting for "New Posts" that permitted the new posts to remain on the list after viewing. vBulletin decided to axe the option of permitting this with vB 4.2.5. You'll note administrators from other forums complaining about it here (https://www.vbulletin.com/forum/forum/vbulletin-4/vbulletin-4-questions-problems-and-troubleshooting/4370232-upgraded-to-4-2-5-and-now-have-search-issues).

...But I've done a bit of manipulation and have restored the old setting (https://anthrogenica.com/search.php?do=getnew&contenttype=vBForum_Post). Tested it. Works exactly as before. :)

The lag with search entries firemonkey picked up has also been addressed. I believe, for the time being, all bugs have been resolved. Please let us know if you notice anything further!

C J Wyatt III
12-31-2017, 02:14 AM
I understand. After looking into the matter, it does look like one of my colleagues tinkered with an old setting for "New Posts" that permitted the new posts to remain on the list after viewing. vBulletin decided to axe the option of permitting this with vB 4.2.5. You'll note administrators from other forums complaining about it here (https://www.vbulletin.com/forum/forum/vbulletin-4/vbulletin-4-questions-problems-and-troubleshooting/4370232-upgraded-to-4-2-5-and-now-have-search-issues).


I appreciate the quick response.

After closing Anthrogenica and reopening it to get the new settings, it works like it used to.

Thanks again.

Jack

DMXX
12-31-2017, 02:26 AM
Just a quick comment to our community;

A 500 Internal Server error is generated every 10-20 minutes. I'm already in touch with our host and we'll hopefully get that fixed soon.